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Overview 

Javelin and Javelin3 PDF readers for MacOS are fast, very small PDF readers that can 
open and view standard PDF files (.pdf) and Drumlin DRM-secured PDF files (.drmx and 
.drmz files). For advice on downloading our special DRMZ and DRMX format files, please 
see the Downloading and Catalogs sections of this document. Note that for security 
reasons Javelin3 for Mac must be run without the Terminal app active. 

User interface 

The screenshots below provide a sample PDF displayed within the Javelin for Mac and 
Javelin3 for Mac readers with the Outline tab area displayed. As can be seen, the Javelin 
readers are based on the standard Apple Mac PDF reader software "Preview". The main 
difference is that when a .drmx or .drmz file is opened it will ask for an authorization 
code before the secured PDF is displayed (on the first occasion).  

 



Javelin for Apple MacOS – User Guide  

Drumlin Security Ltd  04 April 2021 Page: 3 

 

The menus and toolbar displayed are also similar to the Mac Preview program, with the 
File menu being specific to the Javelin program. The items on this menu are described in 
the sections below (File menu). The toolbar includes facilities for navigation, page 
selection, searching text, view modes, zooming and downloading. These are illustrated 
on the screenshot below, with all being essentially the same as in Preview except for the 
download icon (see later in this document for more details). The toolbar can be 
customized (see the View menu item, described later in this document). 
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Markup, Annotation and Text to speech 

Markup 

Javelin readers support markup and annotation. The screenshot below illustrates this for 
a section of a document that has been selected by left-clicking the mouse and dragging 
across the text to be highlighted – this procedure can be carried out for both standard 
PDFs and secured PDFs (drmz files). After highlighting the markup can be removed, line-
by-line by clicking on the line in question and right-clicking to obtain the delete 
highlighting option for that line.  

 

Markup is shown in the selected format as marked blocks of text. Frequently these will 
be a series of lines. Each line or section of a line that is marked can be subsequently 
selected and optionally deleted via right-click on the mouse. Markup will be saved after 
a document is exit-ed.  

Annotation 

In a similar manner, right mouse clicking on a location in the document that is not 
previously selected allows notes to be added (annotation). Two variants of annotation 
are supported: Anchored notes, which are displayed as an icon on the screen, with the 
text displayed when the item is double-clicked (only for older versions of Javelin); and 
Free notes, which are displayed as transparent yellow sticky notes on the page itself. 
Each is described below. For Javelin3 this is implemented with a single note type, 
located where you place it but can be dragged to a new position on the page, and access 
to the notes is available via the Annotations sidebar. 

A new note can be added by right-clicking on a location on a page that is not 
highlighted. Right-clicking on an existing note will enable the item to be deleted. For 
secured PDFs annotations are stored in an external file with extension .nts in the same 
folder as the document. In the first example shown below we have already added an 
Anchored note to the page by right-clicking on the page where we want to add the note, 
and this is displayed as a green annotation icon. Text is then entered in the box at the 
top of the screen. The green icon can be moved around the page by selecting it with a 
left mouse click and dragging it to a new location. The note can be opened by double-
clicking the green icon (left mouse button) and a pop-up form will be displayed allowing 
the content to be viewed and/or edited.  
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The second option is to create a Free floating note, which is similar to an anchored note 
but overlays the page as a transparent sticky note (see example below). In this case text 
entry is via a pop-up form and when OK is pressed the sticky note is displayed. As with 
the icons, sticky notes can be moved around the page and can be edited by double-
clicking them or via right click, or deleted via right click. In Javelin3 annotations are 
save via the File menu during a session and/or when the file is closed. The annotations 
/notes may also be exported to a text file via the File menu in Javelin3. 
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Read aloud (text to speech) 

Read aloud is supported within the Javelin3 for Mac reader, with either page-based 
reading aloud or when reading selected text regions. The standard Mac OSX/Catalina 
"Settings" facility, "Dictation and Speech" option is used to provide this facility.  
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Authorizing documents 

Online authorization 

To authorize a .drmx or .drmz file simply run Javelin, select the File menu, Open… 
option, and pick the file to open. An authorization form is displayed the first time this 
document is viewed, as shown below: 

 

 

Enter the code provided to you by the document publisher (typically a 9-character string 
of text in lower case plus numbers). You can Copy the code and then use the Paste 
button to enter it into the field shown and press OK. You must have an active internet 
connection at this point because the code is checked against our server to ensure it is 
valid. If all is OK the file is opened for viewing, and the process typically does not have 
to be repeated on subsequent occasions.  

Note the DocumentID: 20835 shown on this form – each secure PDF has a unique 
DocumentID and this is used to identify the document on your Mac, even if you change 
the filename (but not the file extension). 

Once authorized a document remains accessible on the device where it has been 
authorized, but copies will not be usable if a copy is made and transferred to another 
device. In some instances (e.g. expiry of number of times a file may be viewed or 
printed) it may be possible to re-authorize a file that has "expired", generally using a 
new code provided by the publisher of the document or the same code may still be 
available for use (if multiple use of the code is permitted or the code is reset for you).  

Removal of authorization 

Occasionally it is necessary to remove authorization for a document that has previously 
been authorized. This can be achieved via the File menu, remove authorization option. 
The simplest way to use this facility is to open the document to be “un-authorized” and 
then select the file menu item. If the document is not already open Javelin will prompt 
for you to enter the documentID of the document in question – e.g. 20835 in the 
example shown in the previous section. Note that removal of authorization for a specific 
device does not make the authorization code available once more – ask the document 
publisher for a code reset or new code if this is required. 
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File menu 

Open, Open recent… 

The Open menu item enables DRMX or DRMZ files and PDF files to be opened and read. If 
a DRMX or DRMZ file is opened for the first time, the authorization process described 
above will be invoked. Once a file has been authorized it can be opened using the File 
menu, Open option, without requiring re-authorization UNLESS some feature expires 
(e.g. number of times it can be printed) and then requires re-authorization or is no 
longer available for that facility. The File menu also displays recently opened files which 
may be selected and will then be displayed. 

Properties 

The Properties menu item displays the properties for PDF files, and in addition, the DRM 
properties (permission settings) for secured PDFs (.drmx and .drmz files). An example 
for a .drmz file is shown below: 
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Save, and Close 

Save is a manual operation to ensure that any markup and annotations made are saved 
as at that moment, thereby ensuring that there is no risk of such changes being lost (e.g. 
due to a computer fault) prior to exit-ing a document. There is no auto-save facility so 
users are recommended to use the Save option regularly if they are making extensive 
markups and/or annotations. 

Close closes the currently viewed file and prompts to save any markup/annotation 
changes made and as yet unsaved. Note that Javelin for MacOS is a multi-windowing 
application so it is possible to have multiple documents open at the same time. When all 
documents are closed only the menu items are displayed, as per other Mac apps. 

Remove authorization 

Removal of authorization is a facility which is provided for two reasons. The first is to 
ensure that the stored information relating to a document and its permissions are 
removed from the Mac, in order to clear these and enable an updating version of the 
document to be re-authorized with new permission settings. This is very occasionally 
necessary, and useful when running tests before documents are distributed. The second 
reason for removal of authorization is where this is agreed with the publisher as a means 
of demonstrating that the document has been removed from the device in question. The 
removal process de-authorizes the current Mac for that document and also logs this on 
the DRM server so the publisher can confirm the action specified has taken place. 

Log file 

Javelin creates a log of the current session which it retains in memory. This includes 
diagnostic information which we may request if you have a technical support issue. 
When selected the option displays a form as shown below – simply provide a convenient 
name for the file and it will be saved on your Mac as a text file, which you can then 
either open and copy the text into an email, or attach to an email for us to review: 

 

Check version 

Manually checks to see if a new version of Javelin3 is available. The Release Notes page 
on the drumlinsecurity.com website provides a summary of updates. 

Page setup and Print… 

Printing from Javelin is very similar to printing from any other Mac application. In fact it 
is exactly the same for PDF files, but for secured PDF files (e.g. .drmz files) printing may 
or may not be permitted. If it is not permitted then a message will be displayed 
explaining this. We recommend only printing a small number of pages at a time, and 
always to a locally attached printer. 
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If permission to print the document has been provided, but the permitted number of 
pages printed or times printed has been reached, a message explaining this is displayed. 
The permitted count can be reset under certain circumstances so ask the document 
publisher or service provider for assistance. For example, the OSCEhome Package 
document whose properties were illustrated earlier does permit printing. In this case a 
maximum number of 1300 pages can be printed. The document itself is shorter than this 
(642 pages) so the publisher is allowing his customers to print the document in its 
entirety twice. Note that even if printing is permitted it is possible that printing will be 
prevented by the software. This will depend on the print device selected – for example, 
printing to a PDF is not permitted (it will result in an error message being displayed 
confirming that you cannot print to or save as a PDF). 

The print Page setup.. form is shown below as an example – note that printing from 
Javelin includes auto-rotate functionality, so a mixed layout document (portrait and 
landscape pages) will print correctly without having to specify the page orientation for 
some pages. 

 

Download file… 

In most instances secured PDF files (with .drmz or, drmx file extensions) will be either 
provided via an email attachment, Dropbox distribution or similar file delivery 
mechanism, or they will be placed on a website and a link for downloading provided. 
Alternatively access to files may be provided via the Catalogs… menu (if provided – see 
Catalogs section below for more details). 

An example of an internet link would be the sample test file: 

http://www.drumlinsecurity.co.uk/ipad/testfonts.drmz  

Note that when you click on a link like this you should make sure the file is downloaded 
to a permanent location on your Mac, not a temp file that is then opened. To be certain 
of this check your Downloads folder to see if the file has been saved there or make sure 
the file is SAVE’d to your Documents folder or Desktop before trying to open it with 
Javelin (via the File menu, Open… option).  

If you have a problem downloading DRMX or DRMZ files from the Internet using Safari 
(for example it puts rubbish text all over your screen) we recommend that you run 
Javelin, select the File menu, Downloads option and enter (or drag in) the web address 
of the file to download and press the Download button.  

http://www.drumlinsecurity.co.uk/ipad/testfonts.drmz
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The Download facility in Javelin allows you to download a drmz or drmx file direct from 
within the program, which can be much easier than using a web browser. When the 
download file menu item or toolbar icon is accessed a form is displayed as shown below. 
You can type in the web address (URL) of the document to download, or if you have the 
address (e.g. in an email) you can drag it to the input field and then press the Download 
button to download the file. This process saves the file to your Downloads folder and 
asks if you would like to open it – if you say Yes, and the file is a PDF, it just opens, but 
if it is a drmz file then it will ask you for an authorization code. Previously downloaded 
files are shown listed in the box below the input field – these can be clicked to re-
download a file if necessary. In general, you do not need to include the http:// bit of 
the web address as the program will recognize that the entry is a URL if it follows the 
basic rules for web addressing. 

 

Catalogs… 

The Catalog menu item displays the form shown below. This menu item is only displayed 
for recent versions of MacOS (e.g. not for 10.10 and 10.11). If the folder icon with books 
is clicked (or automatically refreshed) a set of books and further catalogs is displayed. 
These additional catalogs provide access to titles from a wide range of publishers. 
Alternatively, the URL (web address) of a publisher’s catalog can be entered in the 
download field shown at the top of this form. A catalog URL has the file extension .xml 
or .zip so a typical example would be: www.pdfz.org/test.xml or 
www.pdfz.org/mpbooks.zip  

The left arrow icon takes you back a level, the second icon allows the catalog to be 
refreshed (e.g. if new titles have been added), and the final icon is the action/download 
icon. Right-clicking on a catalog provides additional functionality: Delete catalog, 
Catalog Info, Refresh Catalog, Open catalog folder, Open catalog as text 
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Within a catalog icons corresponding to documents are displayed. Clicking on an entry 
will download that item automatically and then prompt you for an authorization code if 
it is a drmz or drmx file. The book cover image will be displayed if the publisher 
provides one. Right clicking on an entry in a catalog displays an additional menu of 
items: Delete document, Document info, Refresh catalog, Open document folder, 
Refresh document image 
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View menu 

View/hide toolbar 

This is a simple option that enables the toolbar to be hidden in order t increase the 
available screen display area. Note that the View menu option for full screen display 
(see below) provides an extended form of this functionality. 

Customize toolbar 

The toolbar is customizable, simply by adding or removing elements using drag and drop. 
The screenshot below illustrates this, with the default toolbar shown. For example, you 
may wish to add the Print icon to the default toolbar. 

 

Full screen mode/slideview mode 

The View menu includes the option to select Full Screen mode display. This facility 
displays pages in a form suitable for projection on screens, with right and left mouse 
clicks providing forward and backward page movement. The mode can be exit-ed via the 
View menu, Toggle full screen mode, or using the Apple key sequence displayed on the 
menu item (alt cmd F). 
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Additional information 

Additional information relating to the Javelin apps can be obtained by contacting 
Drumlin Security Ltd. Special apps that incorporate functionality similar to Javelin can 
be developed on a bespoke basis. The Taxbooks app, for example, available as a free 
download from the iPAD App Store and Android App Store is a good example of this. 
Information regarding Javelin on other platforms is provided on our website, 
https://www.drumlinsecurity.com  

The secured PDF files used in the Javelin apps are created using the free Windows-based 
software program called Drumlin, available from the Drumlin Security website. Standard 
PDF files are converted to a new file format with file extension .DRMZ – this file format 
can be read on other platforms such as iPAD, Android and Windows using Javelin readers 
for these platforms. For more details, please see the Drumlin Security website. 

https://www.drumlinsecurity.com/
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