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GM E67 Crate Engine ECU CAN Interface to CD Dash

Supported Devices

GM E67 Crate Engine ECUs

CAN Bus Wiring
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GM E67 crate engine harnesses provide switched power, ground, and access to GMLAN (CAN) on a 12 pin
bulkhead connector. AEM recommends you power the CD Dash and access GMLAN (CAN) from this connector. 
The Delphi bulkhead mating connector assembly and terminals must be externally sourced.

Bulkhead Connector Part Numbers
Bulkhead mating connector, 1 required 
Male terminals, 4 required 15304701
Wire seals, 4 required PN 15366021
Plug seals, 8 required PN 15305171
TPA, 1 required PN 15430903

AEM CD has 2 separate CAN ports. For 3rd party devices, AEM recommends you use AEM CAN Bus 2, whose
connections are contained in a 2 pin Deutsch DTM connector. On older harnesses it may be in an unterminated,
twisted/shielded flying lead in the dash harness.

Wiring Recommendation to AEM CD-5/CD-7
GM bulkhead connector pin G (CAN+)  AEM CD port 2 connector pin 1 (CAN 2+).
GM bulkhead connector pin A (CAN-)  AEM CD port 2 connector pin 2 (CAN 2-).
GM bulkhead connector pin L (Switched Power)  AEM CD port 1 connector pin 3 (12V Power).
GM bulkhead connector pin M (Ground)  AEM CD port 1 connector pin 4 (Ground).

A CAN bus network needs two terminating resistors in order to function correctly – one at each physical end of the
network.  The CD Dash has a software selectable internal CAN terminating resistors.  On a typical GM crate
engine install, there's only one terminating resistor on the network, which is located in the GM E67 ECU. AEM has
provided a pre-configured layout for use with GM E67 crate engine ECUs and the Port 2 terminating resistor is
turned on by default.
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Supported Channels

The CD Dash supports 30 channels from GM E67 crate engine ECUs, however basic crate engines may not have
all available sensors installed.  For example, to support 'Fuel Tank Level', a two wire GM fuel level sensor must be
wired into the GM E67 ECU pins J1-9 and J1-44.  Additionaly, an AEM 22 channel CAN sensor module (30-2212)
can be installed to add a vast array of sensor data to the CD Dash.

CH CD CHANNEL NAME

1 AFR Bank 1 Long Term Fuel Trim

2 AFR Bank 1 Short Term Fuel Trim

3 AFR Bank 2 Long Term Fuel Trim

4 AFR Bank 2 Short Term Fuel Trim

5 Ambient Air Temp

6 Baro Pressure

7 Cat Temp Bank 1

8 Cat Temp Bank 2

9 Coolant Temp

10 Distance Traveled While MIL Active

11 Distance Traveled Since DTC Cleared

12 Warm Ups Since DTCs Cleared

13 Battery Voltage

14 Absolute Load

15 Load

16 Engine Run Time

17 Engine Speed

18 EVAP Purge Command

19 EVAP Pressure

20 Fuel Air EQ Ratio Target

21 Fuel Pressure

22 Fuel Tank Level

23 Ignition Timing
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CH CD CHANNEL NAME

24 Intake Manifold Pressure

25 Intake Manifold Air Temperature

26 Mass Airflow

27 MIL State

28 Monitor Status This Drive Cycle

29 Throttle Position

30 Vehicle Speed



SETUP GUIDE

This product is legal in California for racing vehicles only and should never be used on public
highways.  AEM Performance Electronics, 2205 W. 126th Street Unit A, Hawthorne, CA 90250,

Phone: (310) 484-2322 Fax: (310) 484-0152

AEM Setup in DashDesign

AEM has provided a pre-configured default layout to receive, display and log (if using a logging CD Dash) the CAN
bus channel data from a GM E67 crate engine ECU.  To load this, simply open a GM E67 layout and upload it to
the dash.  No additional dash setup or channel configuration is required for general usage however, all elements
within the layout are fully user configurable should you choose to customize the layout to suit your specific needs.
 Go File>Open, navigate to Documents\AEM\DashDesign\Setups\App Specific and select the E67 layout file.  To
load layout onto dash, connect USB cable from dash to PC with dash powered on and go File>Upload to Display
or use keyboard shortcut CTRL+U. 
 
No additional dash setup or channel configuration is required for general usage however, all elements within the
layout are fully user configurable should you choose to customize the layout to suit your specific needs.
 
*NOTE: Verify that dash is on latest firmware before loading layout.  Go Tools>Upload Firmware and load latest
.bin file.

 

Layout Overview

Page 1 & 2 – General 

Additional details:
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· Perimeter gauges: Gauge channels are user configurable – can be set to any channel desired.  Gauge heading
names are editable text.

· Number scaling: The number scale on all four of the perimeter gauges is user configurable and can have its color
and value changed (for units, sensor range, etc).

· Speedometer: “MPH” text can be changed for other units or speedometer can be changed to completely different
channel.
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Page 3 – Lap Timing

Includes lap timing channels for use with either an AEM VDM or GPS Module*.  This page maintains the upper
two perimeter gauges and then displays AFR and Oil Pressure as a numeric read out on the left.  The perimeter
gauges and numeric read outs can be changed to reference any channel desired.  Additional lap timing channel
details:
· Fastest Lap Number: Displays the number of the fastest lap.
· Fastest Lap Time: Displays the time of the fastest lap.
· Predicted Lap Time: Displays the predicted lap time for the current lap based upon progress through the GPS

track map.
· Fastest Lap Time Delta: Displays the difference in seconds between the last completed lap and the fastest lap. 

Negative deltas (faster) display as green and positive deltas (slower) display as red.
· Predicted Fastest Delta Bar: Graphically displays the delta time between the predicted lap time and the fastest

lap time.  Faster displays as green and slower displays as red.

*If not using an AEM VDM or GPS Module for lap timing, Page 3 can be replaced with either Page 1 or 2.  With
Page 3 selected as the active page, go Edit>Paste Screen From Setup File, open the same AEM 5 Gauge layout
file and select the desired page to import.     
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Page 4 – Diagnostic

The diagnostic page allows you to check over many important channels quickly and easily.

Warnings and Alarms

Warning Bar

This layout utilizes a number of different warnings, alarms, and icons to notify the driver of problems and their
severity.  A warning is generally used to report non-urgent conditions that the driver should be aware of but
continue operating the vehicle.  Warnings are viewable on any of the four main layout pages and icons vary per
page.  A warning will be triggered and continue to display so long as the trigger conditions are still valid.  Warnings
cannot be forcibly cleared.



SETUP GUIDE

This product is legal in California for racing vehicles only and should never be used on public
highways.  AEM Performance Electronics, 2205 W. 126th Street Unit A, Hawthorne, CA 90250,

Phone: (310) 484-2322 Fax: (310) 484-0152

The red warning bar and warning message text are two separate elements that are triggered by output 
WarningBarTrigger which is an alarm that references the following channels:

The warning will be triggered if channels WarningCoolantTempHigh or WarningFuelPressLow are 1.  Note that
WarningFuelPressLow has been set to 2 to disable it from triggering the warning.  If a fuel pressure sensor is being
used, the value may be set to 1 in order to trigger the warning in the event of low fuel pressure.  

Indicators
The AEM provided GM E67 ECU layouts utilize a few indicators with pre-defined trigger criteria.  Additional
indicators can be added as well as existing indicators be edited or removed.

The arrow indicators are configured as turn signal indicators and will trigger when the 'Spare1' (right) and
'Spare2' (left) inputs are grounded.

The light low beam indicator will trigger when the dimmer (headlight) input is provided 12V.

The charge malfunction indicator will trigger when battery voltage is below 11.5 volts and engine speed is >400
RPM.  This can be reconfigured by editing the 'WarningBattVoltsLow' output.

The check engine indicator will trigger when the 'MILIndicatorState'' output is active.  This can be reconfigured by
editing the 'IndicatorMIL' output.

The coolant temp high and coolant temp low indicators will trigger when coolant temp is above 220 degrees F (red)
or below 140 degrees F (blue).  This can be reconfigured by editing the 'Coolant_Icon_Index' function.
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The low fuel level indicator will trigger when fuel level is below 10%.  This can be reconfigured by editing the
'WarningFuelLevelLow' output.
Note: A two wire GM fuel level sensor must be wired into the GM E67 ECU pins J1-9 and J1-44 for the fuel level
gauge and indicator to function.

The turbo indicator will trigger when the boost pressure is above 10 PSIg.  This can be reconfigured by editing the
'WarningBoost' output.

The GPS indicators will trigger when a satellite connection is acquired (green) or lost (red).

Alarm Page

Alarms are generally used to alert the driver to a severe condition that could potentially cause engine/vehicle
damage and vehicle operation should be stopped immediately.  When an alarm is triggered, the Alarm Page is
displayed on the screen along with an alarm message.  An alarm can be cleared or “ignored” by the driver by
pressing the left button on the dash.

Alarms are configured similarly to warnings with one significant difference.  There are separate alarm outputs that
appear similar to the warning outputs but typically have more severe trigger thresholds.  For example, the warning
for high coolant temp is triggered at 220 F but the alarm for high coolant temp is triggered at 230 F.  The trigger
criteria for the Alarm Page is configured by going to Setup>Alarm Page.  The Alarm Page Setup references all the
alarm outputs in the layout.
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NOTE: Warnings and alarms for low fuel pressure are built into the layout but have been “disabled” by setting their

engine speed reference to be >12,000.  To make these functions active, set to a pertinent value; ie 3000 rpm. 

Shift Lights & LEDs

Shift lights and LEDs are configured in Setup>Shift Lights and LEDs.  This layout sets the shift lights to start at
5250 rpm, go full scale at 6750 rpm and flash at 7000 rpm.  The shift lights progression range can be configured in
Shift Light Setup> Auto Create Outputs.  The first shift LED is turned on at the Start rpm and then following LEDs
are turned on based on the Offset value.  To find the correct Offset value, take the full rpm progression range and
divide by 7.  For instance, for shift lights that start at 5000 rpm and end/flash at 7000 rpm, take full rpm
progression range of 2000 and divide by 7 (Offset = 285).

Logging
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If using the logging version of the dash, the incoming CAN bus data channels can be recorded in a data log for
later analysis.  The GM E67 Crate Engine ECU layout file is already setup to log with a good selection of useful
channels.  Logging is set to start/stop based on output EngineSpeed so logging will be active whenever the engine
is running.  To view the logging setup or make changes, go Setup>Logging. 

Logs are downloaded from the dash using the AEMdata software.  With the AEMdata software open, simply
connect the USB cable from the dash to the PC with the dash powered on and the software will automatically
detect the dash and that it has logs to download.

Click on Download Data and you’ll be prompted to select the sessions to download.  Be aware that all the
individual log sessions selected will be downloaded as a single .daq file.

Once you click on OK, you’ll be prompted for a file name and save location.  

TIP: Because multiple log sessions are downloaded as a single .daq log file through AEMdata, you may choose to
eliminate unuseful data (warm up, long periods of idle, etc) to shorten the log to only contain data you’re interested
in analyzing.  This can be accomplished by trimming the log data.  To do this, select the log data to be kept (click
& drag) and then go File>Trim Log File.  Select the channels to be included in the new trimmed .daq file, click on
Export and select a file name and save location.  You will now have a new trimmed .daq file. 


	GM E67 Crate Engine ECU

