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Getting started in
FeatureCAM

FeatureCAM is a CAD/CAM software suite that automates machining
and minimizes programming times for parts on mills, lathes, and
wire EDM.

_(} - The functionality available to you depends on which
components you have licensed.

FeatureCAM generates toolpaths based on the features of the part,
and automatically selects appropriate tools, determines roughing
and finishing passes, and calculates feeds and speeds.

This Getting Started guide provides step-by-step instructions that
highlight some of the features of this versatile software.
FeatureCAM is very easy to use, and does not require any specialist
computing knowledge.
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Starting FeatureCAM for the first time

1 From the Start menu, select All Programs > FeatureCAM >
FeatureCAM.

CP You can also start the program by double-clicking the

FeatureCAM [l icon on your desktop.

The first time you start FeatureCAM, it runs a program to create
the tools and materials database.

2 Click OK to begin the configuration. This displays the Tool and
Material Setup dialog.

Tool and Material Setup @

m ‘Where is your database located 7
b=

* On my local computer.
(Most users will choose this option)

" On another computer that | will access over a networls.
(This option is valid anly f you have purchased the Shared

Metwork Database module)

| Meod = | Cancel |

3 To create a local database, select On my local computer.

If you want multiple computers to share the same tool and
material information:

a Select On another computer that | will access over a network.

b Click the Browse button, and use the Database Location dialog
to select the folder where the database is located.

) You need to create a database folder on your network first,
and then copy an empty MDB database from the
FeatureCAM CD-ROM to this location. The default database
is created by MS Access, and should be accessed using the
MS Jet database driver. You may use a different database
type, such as MS SQL Server. For more information, refer
to the online help.

& You need to have the Shared Network Database module to
use this option.

4 Click Next.
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5 Choose the tools to load:

Tool and Material Setup ﬁ

m Your tooling database will be initialized or
upgraded now.
b=

Choose the type of tooling that will be used to
manufacture your parts. Or, what tools do you have in
your shop?

* Inch
" Metric
" Both

< Back | Mext | Cancel

Inch - loads only the inch tools.

Metric - loads only the metric tools.

Both - loads both inch and metric tools.
6 Click Next.

If you chose to load both tool types, you are asked which tool
type you use more often. Select Inch or Metric, and click Next.

8 Click Finish to initialize the database.

&  The tools database specifies the set of tools used by
FeatureCAM to perform manufacturing operations. For best
results, use the Tool Manager (available from the
Manufacturing menu) to customize the database to reflect the
tools in your shop.
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Creating a new file

Starting FeatureCAM displays the New Part Document Wizard.

-
Mew Part Document Wizard

=)

What do you want to do?

m @ New file

@ () Open an existing file

Show this dialog on program start

L

< Back i Mesd > ]’

Cancel | | Help

)

A

1 Select New file in the New Part Document Wizard, and click Next.

2 Choose a Type of Milling Setup.

-

MNew Part Document Wizard

=)

What kind of part file would you like to make?

Tums/Mill

Milling Setup

&/
\

Muttiple Fodure

Tombstone Fidure

E' Simulation Machine Design

Unit of Measure:

@ Inch () Millimeter

| <Back || Finish

) ] |

Help

)

L

A

3 Select the Unit of Measure (Inch or Millimeter).

I=C? You can change the default dimension units later, by
selecting Options > File Options from the menu.

4 Click Finish.

4 « Getting started in FeatureCAM
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Screen layout

The FeatureCAM interface contains a number of standard Windows
elements, such as toolbars, dialogs, context menus, and wizards.
( FeatureCAM (Milling] - [FM1] ® o0

|y v=ircoma

,"—" 7. Features
U & Toolpaths
%:.9 NC Code
4 r
e o

Select something. or click-and-drag a box selection a

Eﬂ Properties 0

X ye £S5 _Se Se 30559.CNC | too 2 cores |
| x¥| Inch | Layer1 | UCS Setupl | Setupl | BOSSI.CNC | tools | 2 cores |

@ Title bar displays the type of part setup in round brackets, in this
case (Milling), and the name of your part file in square brackets, in
this case [FM1]. When you have any unsaved changes in your part
file, an asterisk (*) is displayed next to its name.

(2 Menu bar provides access to a number of menus. Selecting a
menu, such as View, opens a list of associated commands and sub-
menus. Sub-menus are indicated by a small arrow to the right of
the text. For example, selecting View > Principal Views » displays a
list of commonly used views.

@ Toolbars provide quick access to the most commonly used
commands in FeatureCAM.

@ The graphics window is the main working area.

(® Toolbox window with the Steps panel, Part View panel, and
Browser.
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The Steps panel contains an ordered list of steps for creating part
programs. Each step is a wizard that presents a series of dialogs
for each process. They are listed in the order in which you should
use them during the process of creating a part program.

The Part View panel provides a hierarchical view of the part.

The Browser contains information on the latest features available
in FeatureCAM, including example files that you can load straight
into FeatureCAM.

(®) Results window contains the automatically generated
documentation including tooling lists, setup sheets, and the NC part
programs. Selecting one of the tabs at the bottom of the window
changes the content of this window.

(@ Assistance bar displays help for the current command.

® Feature/Geometry Edit bar lets you select and edit a feature, or
enter the point locations and parameters for geometry creation.

(© status bar shows your current drawing units, tool crib, and post
processor settings, as well as your keyboard status and information
about the simulation when you run one.

Getting help

FeatureCAM provides a variety of ways for you to get help. Context-
sensitive help displays help for the current task. You can also refer
to the numerous examples in the Examples folder, located in the
FeatureCAM root directory. Finally, if you cannot find an answer to
your question, you can visit our website or contact our technical
support.

Online help

The online help documentation is your primary source for in-depth
technical information about FeatureCAM. It covers all FeatureCAM

modules, and is accessed from the Help menu, or by clicking on
the toolbar.

Context-sensitive help

You can use one of the following methods to get help relevant to the
current task:

= Some commands automatically display the help in the Assistance
bar.

Step 1: Pick point
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= Hovering the mouse over a toolbar icon displays a brief
description.

l‘b‘ )

= Pressing F1 displays the relevant help page.

= Most FeatureCAM dialogs have the Help button. Clicking it
displays the relevant help page.

= Click the Context Help button on the toolbar. When the cursor
has changed to a question mark (?), click a menu item, button or
dialog for more information.

Links

You can find FeatureCAM information from the Help menu:

= Help > FeatureCAM on the Web for product news, online support,
training information, discussion forum, and mailing list.

= Help > Check for a FeatureCAM Patch for product updates.

= Help > FeatureCAM API Help for documentation on the FeatureCAM
API (Application Programming Interface).

Technical Support

If you have any questions related to FeatureCAM, which you cannot
find an answer to in the documentation, you can contact the Delcam
technical support service. Email support@featurecam.com,
describing your problem as precisely as possible. This support is
free for the first 60 days after your initial purchase and 30 days
after the purchase of an upgrade.
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Introduction to 2.5D
milling

This example shows you how to create some simple features,
generate toolpaths and output the toolpaths used to machine the
part.

1 Start FeatureCAM (see page 2).

Create a new file (see page 4).

Create the stock (see page 8).

Create the features (see page 9).
Viewing the part (see page 12).
Simulating the toolpaths (see page 13).
Part documentation (see page 19).

0 N OO g A~ OB

Controlling the automation (see page 20).
9 Changing the post processor (see page 22).
10 Generating NC code (see page 21).

11 Tool mapping (see page 22).

12 Saving the NC code (see page 23).

Defining the Stock

The stock is the initial material from which you cut your part. When
you create a new part, the Dimensions page of the Stock wizard is
displayed. It enables you to determine the shape and dimensions
for the stock, the stock material, part program zero, and the
coordinate system for modeling.
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1 On the Dimensions page of the Stock wizard:

i '
Dimensions

What shape is the stock: @) Block
) Round
() N-Sided

Enter the dimensions of the stock:

Thickness
1.0000
Width Length
40000 5.0000
<Back || Net> |51 Bnish|,| | Cancel | [ Hep |
|| "y

Enter a Thickness of 1 (25 mm).
Enter a Width of 4 (100 mm).
Enter a Length of 5 (120 mm).
d Click Finish.
2 Click OK to accept the default values of the Stock wizard.

O T 9o

Creating the features

This step shows how to create Hole and Rectangular Pocket

features.
English units Metric units
4.000 f=—— 95.000 —
_ﬁu..?suﬂi L ".“.-".‘50. . B - [V 1e000 D12.0
— y s
&' LN b s © 75.00
Ll | I b
L ws_mq N
2500 ¥ Pl ) ? e o T
.I["]l] P L L 25.000 —={ b a
f —L}E 1.|]|]Eﬁ-=d— T 120.000
fo— 2.500 —
L.000

1 Create a Hole feature.

a Click the Features ﬁ step in the Steps panel.

In the New Feature wizard, select Hole in the From Dimensions
section, and click Next.

c Enter a Diameter of 0.5 (12 mm), and click Next.
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d Enter a hole center location of X 1.0 (25 mm) and Y 1.0 (25
mm), and click Next.

This displays the Strategies page. This page controls the types
of operations used to cut the feature. The default operations
for a Hole feature are to spot drill and then drill the hole. If
the Hole has a chamfer, the default is to cut the chamfer with
the spot drill operation.

e Accept the default strategy settings by clicking Next.

The Operations page shows a summary of the operations to
cut the feature, the automatically selected tools, and the
feeds and speeds.

-
Mew Feature - Operations

The following operations will be created to machine this Hole
feature:

COperation Tool Feed Speed
M hole
= spotdill  certer M3150... 0.00761.. 1872R..
= dil TD_05000_1[2J 0.00751.. 1509R..

Click "Finish’to create the feature. Click ‘Next” to change tools
and/or feeds and speeds for each operation.

| <Back || Next> |[[#1 Finish|,| | Cancel | | Hep |

From the Finish menu button select the Finish
option.

- %A Finish =
@ Finish and Edit Properties
@ Finish and Create More

2 Create a Rectangular Pocket feature.

Click the Features @ step in the Steps panel.

In the New Feature wizard, in the From Dimensions section,
select Rectangular Pocket, and click Next.

Accept the default dimensions by clicking Next.

Enter a pocket location of X 0.75 (15 mm), and Y 2.5 (60 mm),
and Z 0 (0 mm), and click Next.
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The Strategies page shows that roughing and finishing
operations are created.

P
Mew Feature - Strategies

What strategies would you like to use to cut this Pocket feature?

Climb mill [ Minimize tool retract
[ Individual rough levels [ Cutter comp
Depth first Partline program
Operations
[ Pre-drll
=
2
Rough pass
Bi-directional Stepover type:
rough ’Spilﬁl VI
Finish pass
[ Semifinish pass
[ Use finish tool [ Bottom Finishing... ]

Ramp from top

| <Back || Next> |[[#% Finish|,| | Cancel | | Hep |

e Click the Finish button.

3 Use the Features ﬂ step to create a second Hole with a
diameter of 0.5 (12 mm), located at X=4 (95 mm) and Y=3 (75
mm).

4 Use the Features ﬂ step to create another Rectangular Pocket
the same dimensions as the first, but positioned at X=2.5 (55
mm), Y=0.5 (15 mm).

T
1T 9

an | )
@/\ 1

X

5 Select File > Save, and save the part as milling.fm.
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Viewing the part

To look at the part in a different orientation you can select one of
the standard predefined views. These options are available from the
Standard toolbar:

PR b @ e @ N.D @w v

1 To change the view to an isometric view, click the Isometric
button on the Standard toolbar.

2 To change the view to a front view, from the Principle View
menu button, click the Front IEI button.

.
I3 FeatureCAM (Milling) - [milling2]

F File Edit View Construct Manufacturing

Isometric
Isometric 2
Isometric 3

Isometric 4

TFROOFOO=

Top
Bottom
Front
Back
Left
Right

LEOMENZA®® (@
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3 Click the Isometric button to return to the isometric view.

Simulating the toolpaths

Now you have created the features, FeatureCAM automatically:
= Selects the most appropriate tools and operations;

= Recommends machining strategies;

= Calculates speeds and feeds;

= Generates toolpaths and creates the NC code.

To view the simulated toolpath:

1 Click the Toolpaths “ step in the Steps panel. This displays the
Simulation toolbar.

2 Select the 3D Simulation option, and then click Play E to
start the simulation. If the Automatic Ordering Options dialog
appears, click OK to close it. This accepts the default ordering
options.

This displays a solid 3D rendering of the cutting process.
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¢ If all tools are displayed in gray in the simulation, select
Options > Simulation > General from the menu, and select
the Tool Colors option, then click OK to close the dialog.
This displays tools in different colors so you can see which
features are machined by each tool.

Click the Play E button on the Simulation toolbar to see
the changes.

3 Click the Play to Next Operation button. This displays the spot
drill operation.

4 Repeat step 3 to view each subsequent operation until you
complete the simulation.

5 Click Eject EI This removes the Simulation toolbar.
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Order of manufacturing operations

The Op List tab in the Results window shows all of the operations
needed to machine the features. A yellow warning & sign next to an
operation indicates a potential problem with that operation. In this

case, if you see any warnings ignore them.

Operation List
7l (D Automatic Ordering

@ Manual Ordering

R Operation

= spotdrill

A spotdril

drill

drill

rough pass 1

rough pass 1

rough pass 2

finigh

rough pass 2

finigh

Results

lv wircoma

S I G O

Feature
halel
hale3
halel
hale3
rect_pock1
rect_pock?2
rect_pock1
rect_pock1
rect_pock?2
rect_pock?2

< | I

I%opusn |@m @Nccade_

FeatureCAM 2015 R3 Getting Started

Tool

center_5
center_5
TD_05000_1[2:J
TD_05000_1[2:J
endmill 0500:req
endmill 0500:req
endmill0375:req
endmill0375:req
endmill0375:req
endmill0375:req

k
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This section looks at:
= The automatic ordering options. (see page 16)
= The manual ordering options. (see page 18)

Automatic ordering operations

You can control the automatic ordering of operations by using either
rules or operation templates. The turning tutorial looks at operation
templates (see page 38).

1 Select the Automatic Ordering option on the Op List tab. This
ensures the automatic ordering rules are applied to the
operations.

2 Change the automatic ordering to group together the operations
which use the same tool.
a Click the Ordering Options button.

b In the Automatic Ordering Options dialog, select Minimize tool
changes, deselect everything else, and click OK.

Automatic Ordering Options

Automatic operation ordering iz controlled with 0K
these options:

tinimize tool changes Cancel
[ Do finizh cuts last
[ Cut higher operations first

"

Help

[ Minimize rapid distance

3 Simulate the part.

a Select the Toolpaths ﬂ step from the Steps panel.
This displays the Simulation toolbar.

b Click the 3D Simulation button.

¢ Click the Play EI button.

If the Automatic Ordering Options dialog appears, click OK to
close it. Notice that the simulation first performs all the spot-
drills, then the drills, and then the rough and finish milling for
the pockets.

d Click the Stop E button when simulation is complete to exit
the simulation mode.

4 Change the automatic ordering to move the finish operations to
the end of the list.
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a Click the Ordering Options button.

b In the Automatic Ordering Options dialog, select Do finish cuts
last, deselect everything else, and click OK.

i "
Automatic Ordering Options Iﬁ
Automatic operation ardering is contralled with

thesze optionz:

[] Minimize tool changes
Do finish cuts last

[ ] Cut higher operations first
[] Mirimize rapid distance

This changes the order of operations in the Operation List.
5 Simulate the part.

a In the Simulation toolbar, click Play E
The finish cuts for the two pockets are now cut last.

b Click Stop EI when simulation is complete.

6 Change the automatic ordering to match the order of the
features in the Part View panel.

Click the Ordering Options button.
Deselect everything, and click OK.

¢ Open the Part View panel by clicking on | PatView
The tree view contains all the setups and features you have
created.

d Click the rect_pock2 item in the Setup1 node, and drag it up
above hole2.

h Part Wiew
milling. frn
n' Machining dttibutes. ..
@ stockl
- #ly Setupl
[ rect_pock] ﬂ
M@ rect_pock? .
& holel rect_pockl
M@ hole2
s Stock Models

7~ Curves
A Sufaces

7 Simulate the part.

a In the Simulation toolbar, click Play E
The second pocket is cut as the second feature.

b Click Stop IEI

FeatureCAM 2015 R3 Getting Started Introduction to 2.5D milling « 17



Manual ordering options

The automatic ordering of operations determined the order by a set
of rules. You can also specify an exact ordering of operations

manually.

1 Select the Manual Ordering option on the Op List tab.

2 In the Fixed Operation Ordering dialog, select Do Not Show This

Warning Again, and click OK.

-

Fixed Operation Ordering

Switching to Fired QOperation Ordering. Wwhen uzing Fised
Ordering, vou can drag-and-drop operations up and down, and
thew will stay vahere pou put them,

Fresz O to uze Fived Operation Ordering.

Do ot zhow this warning again.

=)

s

A

3 Select the spotdrill operation for hole2 from the list, and drag it
up ahead of the drill operation for hole1.

4 Simulate the part.

1] Operation List

5 6 @ Automatic Ordering o —

E @ Manual Ordering Tél 3“ i @ ﬂl @ 0

; R Operation Feature Tool

[ =) spotdiil hole1 center 5

W drill hole1 TD_05000_112-.
rough pass 1 rect_pock endmill 0500reg
rough pass 2 rect_pock2 endmill0375reg

_________ finigh rect_pock2 endmill0375reg
R spotdrill hole2 center 5

drill hole2 TD_05000_1[2:
rough pass 1 rect_pock1 endmill 0500reg
rough pass 2 rect_pock1 endmill0375reg
finigh rect_pock1 endmill0375reg
Results

a In the Simulation toolbar, click Play E The simulation
performs the operations in the new order.

b Click Stop EI when simulation is complete.

Selecting Automatic Ordering to return to automatic ordering.

Click OK to close the Automatic Operation Ordering dialog.

& Ir you want to erase the simulation and remove the

Simulation toolbar, click Eject E

18 « Introduction to 2.5D milling
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Part documentation

As well as simulating the part manufacture, the simulation
generates tool and operation lists. The tools selected are based on
your tool database. You can print this information to use as an
operator's checklist, using the File > Print menu option.

1 Click the Details tab in the Results window to display the

Manufacturing Operations sheet.

Manufacturing Details

© Operation List
@ Tool List

MANUFACTURIMNG OFERATION ZHEET Ji

Part:
Setup:
Diate:
Stock:
hdat:

Ope
Fis:
Tool:
Center:
Depth:

milling2

Setupl (1 of 1)

Thursday, Juby 21, 20171 14:46:43

L 5.0000 0n. « Wy 4.0000 in. T 1.0000 in.
ALURINURA, 1171.00 Brinell.0.30 HF min/in™

holel (spotdrill)

2182 R, 1.006E IFR

#1 (center_5, 04375 in.)

0.0000n, 0.0000n. 0.0000 in.

0.4040in. £

Warning: TSBO2W: Toaol diameter 0.437500 is sma

Op: 2
Fis:
Tool:

The default spot drill diameter and edge b

hale1 (drill
1909 RPM. 0.0075 IPR
#2 (TD_05000_1)2:.. 0.5000 in.)

2 Select the Tool List option at the top of the Details tab to show
the Manufacturing Tool Detail sheet. It contains all of the tools
used to create the part based on the tool crib you selected.

Manufacturing Details

@ Operation List
© Tool List

MANUFACTURING TOOL DETAIL SHEET

Fart:  milling2

Setup: Setupl (1 of1)

Date:  Thursday, July 21, 2017 14:46:43

Crib:  basic

Summany:

Slot1: center b D018750n. L
Slot2:  TD_05000_1)2:d D 0.5000 in. L4
Slot3: endmill0500:reg 005000 in. La
Slotd: endmill0375:reg D0.37500n. La
Tool MNarme: center_h

Tool SlotNa.: 1

Tool Camp. No.. 1

Tool Offset Mo 1

FeatureCAM 2015 R3 Getting Started
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Controlling the strategies

You can control the strategies used to manufacture the part from

the properties dialog.
1 Open the Part View panel.

2 Right-click on hole1 under the Setup1 node, and select the
Properties option.

a2 Part View

[ miling

----- {JE Machining Aftributes...
..... @ stocki

A XONFOO-

hﬁ' Properties... Alt+Enter

b Cut Ctrl+X
5.21 Copy Ctrl+C

----- W rect pockl
WM rect_pock?
& Stock Models

3 In the Properties dialog:

i R
Hole Feature Properties - holel ﬁ
[l Iﬁﬁl Dimensions | Location | Strategy | Misc
= [] Combine with similar holes into canned cycle
Retract to Z rapid plane
(@ Retract to plunge clearsnce
Drill Operations
Machining Type: @ Drill onby (0 Dill, /Ml
(| Spot dril Attempt chamfer w./ spot
[ Pilat il Filat diareter(z)=
Dirill
[]Ream Ream before chamfer
[ Bore
Click on an operation to
set its attibutes and
feeds/speeds
[ ok || cance || Apply Preview Help
b

a Select the Strategy tab
b Deselect the Spot Drill option
¢ Click OK.

4 Select the Toolpaths ﬂ step from the Steps panel.

5 In the Simulation toolbar, click the 3D Simulation button, and

then click Play E to start the simulation.
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“& There is no spot drilling for the first hole. If you look
through the operations list, there is only one spotdrill
operation listed. FeatureCAM optimizes the part
manufacturing process, but you control the level of

automatic optimization.

6 Click Eject EI This removes the Simulation toolbar.

Generating NC code

FeatureCAM generates the NC code to manufacture parts on a CNC
machine. You can generate NC code after you have simulated the

part, and therefore calculated the toolpaths.

-
1 Select the NC Code '\j\’ step from the Steps panel. This displays

the NC Code dialog.

2 Click the NC Program 'E_HI button to generate the code.

NC Code

M10G70GI4G7EGE0
'millingz 7-21-2011"
'HOLE1!

TOOL NUMBER:T!
'SPINDLE RPFk:2182"
M35GOX0 YD TTME
M4052182

45200,
MEOZ0104E
MMEEGETZ0.504F14.3
HEOD.

MMEEGED

MNZ021.0

'HOLE1!

TOOL MNUMBER:Z'

' SPINDLE FFM:19049'
MNA0GOX0 YD TZME
M95GH4F14.351904
100050

M10520.1
MIT0GE321.2680220.620.25F14.3
1150,

M120GE0

M12521.0
M1304.0v3.0201
M135GE321.260220.620.25F14.3
140x4.0

M145GE0

M15021.0
'RECT_POCKZ!
TOOL MNUMBER:'
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Tool mapping

To change the location of the tools in the tool changer:

-
1 Select the NC Code &:’ step from the Steps panel. This displays
the NC Code dialog.

1
2 Click the Tool Mapping yz button. This displays the Tool Mapping
showing the current tool order.

Tool Mapping [ﬂ]
+ | Name Diam... Length ID Crib Time Diist Holes 0k
1 center_5 1 1 1 1
2 |- TD_05000_112: 2 2 2 2
3 endmill0500:req 3 3 3 1 min 20in.
Hel
4 endmill0375:regq 4 4 4 1 min 21in.
5
Sl a0 A iet & Show Al Tools Saved in Crib
Vel s 5 Set Shov empty tools slote
Diarneter offzet register number 1 Same
Length offzet register number 1 —
Tool ID ] Clear in Crib
Tool life for center_B
Enable/dizable tool change to new tool after specified Taal Life Setal
time, niumber of operations, etc
Rezet Al

3 To move the center drill to the 5th position in the tool changer:
a Select Center_5 in the table.
b Enter a Tool Number of 5 in the Slots frame.
c Click Set.

_{} "~ You cannot change the number in the table.
4 Click OK to save the changes, and close the Tool Mapping dialog.

Changing the post processor

To change the post processor:

1 Select Manufacturing > Post Process from the menu. This displays
the Post Options dialog.

2 Click Browse to view available post processors.

The default folder for posts is C:\Program
Files\Delcam\Examples\Posts.
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3 Select your post processor and click Open.
The new post processor is displayed in the CNC File field.

4 Click OK to exit the Post Options dialog and use the new post
processor; click Cancel to exit the dialog and keep the original
post processor.

5 Select the Toolpaths ﬂ step from the Steps panel.
Run a simulation of the part to regenerate the NC code.

Saving the NC code

To save an NC program:

-
1 Select the NC Code ‘%\ step from the Steps panel. This displays
the NC Code dialog.

E
2 Click the Save NC button in the NC Code dialog.

In the Save NC dialog, accept the default filename and folder,
and click OK.

rSave NC @1

MEC Output Directory

@ Save to cument directary:
E:\FeatureCAkd\Getting Started

() Save to other directony:

Browse...

MC Pragram Mame

@) Use the base file name for all NC programs. S etups vil
be named -2, -3, etc.

File Name:  miling2. TET
[ Save MC Program Using Short File Mame

) Use the zetup Part Marme for each MC program file

Selection
@ All Setups () Current Setup
Operations List Toal Data
Tools Ligt of Al Setups F/5S Data
Toals List of Each Setup M achining Configuration
HC Program
[7] Create Subfolder [] Owenvarite Existing Files
[ QK ] [ Cancel ] l Help
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Introduction to turning

This tutorial shows you how to create a simple part, generate
toolpaths and output the toolpaths used to machine the part.

1 Start FeatureCAM (see page 2).

2 Create a new file (see page 4), but select a Type of Turn/Mill
Setup or Turning Setup.

Create the stock (see page 24).
Preparatory steps (see page 26).
Defining the geometry (see page 27).
Creating the features (see page 30).
Viewing the part (see page 35).

0 N O a A~ W

Simulating the toolpaths (see page 37).

9 Order of manufacturing operations (see page 38).
10 Part documentation (see page 40).

11 Changing the post processor (see page 22).

12 Generating NC code (see page 41).

13 Saving the NC code (see page 23).

Defining the stock

The stock is the initial material from which you cut your part. By
default, the Stock wizard (Dimensions page) opens on the screen as
soon as you create a new part. It enables you to set the shape and
dimensions for the stock, the stock material, part program zero, and
the coordinate system for modeling.
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1 On the Dimensions page of the Stock wizard:

-
Dimensions

What shape is the stock: () Block
@ Round
() N-Sided
Enter the dimensions of the stock:

- oD
4
lengh ~ fe———=] DD
5 0
<Back [ Ned > | [ Enish|.| | Cancel | | Help |

~

A

a Enter an OD (outside diameter)
b Enter a Length of 5 (125 mm).
c Enter an ID (inside diameter) of
d

Properties option.

W Finish

E' Finish and Edit Properties

of 4 (100 mm).

0 (0 mm).

From the Finish menu button select the Finish and Edit

This displays the Stock Properties dialog.

click OK.

In the Stock Properties dialog enter a Z of 0.0625 (1.5 mm), and

-
Stock Properties - stockl

===

Dimensions | ndexing

® stock?

ALUMINUM

) Block ) N-Sided

B & Hardness (Br): 111
@ Round () Userdefined 1o, 0 90 4P min/in"3

k| x [o0000 ] v [o.0000 z 00625
oK ]| cancel || Apply Help

FeatureCAM 2015 R3 Getting Started

Introduction to turning * 25



Preparatory steps

The preparatory steps determine the coordinate system and tool
crib.

1 Select Options > Turning Input Modes > 3D (XYZ) from the menu to
enable you to enter coordinates as X, Y, and Z values.

2 Select Manufacturing > Set Tool Crib from the menu to display the
Select Active Tool Crib dialog.

Select the tools option from the Crib List, and click OK.
To display the complete part:

a Click the Rotate View menu button to display the View
menu:

AL L@ B B
'{-' Rotate
Trackball
'—E' Pan and Zoom
Eﬂ Rotate X
t-'!.‘.r Rotate v
?j Rotate 7

+ Pan

+—+| 7oom

:I:[ Box Zoom

IE Center All
% | Center Selected
¥ Center Selected Point

b Click Center All 3%,
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Defining the geometry

This shows you how to design your part.

1 Draw two lines:

a Click the Geometry EHT step in the Steps panel. This displays
the Geometry Constructors dialog.

Geometry Constructars @

wihat geametry constructar do you want to uze?

Poirt L

Lre Sh—tak
Circle ClOJZFCIChe!
Fillet - L'_ E: _ﬂ

Arc Cee=

Dimension HI%J’JJAm@
Edit/Clip ¥ A S

[ Create more than 1

b Select the Create more than 1 option, and click the Line from
two points -~ button. This displays the Feature/Geometry Edit

35000 uL 2 2361 Create A

c Create two lines that define the outer profile, in the
Feature/Geometry Edit bar:

For point 1, enter an XYZ1 of X 2 (50 mm), Y 0, Z -3.5 (-88
mm).

For point 2, enter an XYZ2 of X 1 (25mm), Y 0, Z -3.5 (-88
mm).
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Press Enter. This draws a line in the graphics window.

d Create a second line:

For point 1 enter an XYZ1 of X1 (25 mm), Y 0, Z -3.5 (-88
mm).

For point 2 enter an XYZ2 of X1 (25mm), Y 0, Z 0.

Press Enter to create a second line.

................... ¥
2 Create a chamfer to trim your lines.
Click the Geometry i3 step in the Steps panel.

In the Geometry Constructors dialog, in the list of Fillet options
click the Chamfer button.
¢ In the Feature/Geometry Edit bar, enter:
A width of 0.25 (6 mm).
A height of 0.25 (6 mm).

d Position your mouse pointer close to the chamfer location. The
chamfer snaps into place.

28 « Introduction to turning FeatureCAM 2015 R3 Getting Started



e Click to place the chamfer on your drawing. The chamfer
automatically trims your lines.

3 To turn the part you need to convert these three individual lines
into a single curve (chain the curve).

a Select the Curves B step from the Steps panel.

b In the Curves Creation dialog, select the Pick Curve Pieces
L’ button.

¢ In the graphics window, click locations @, @, and 3. Each
line segment changes color when selected.

d In the Feature/Geometry Edit bar, name the curve turn, and
press Enter.

4 Create third line which you will use to create a Bore feature.

T

a Click the Geometry it step in the Steps panel.

b In the Geometry Constructors dialog, click the Line from two
points <~ button.

¢ In the Feature/Geometry Edit bar:
For point 1 enter an XYZ 1 of X 0.625 (16 mm), Y 0, Z 0.

For point 2 enter an XYZ 2 of X 0.625 (16 mm), Y 0, Z-3.75 (-94
mm).

d Press Enter.
5 To chain the bore curve:

a Select the Curves B step from the Steps panel.

b In the Curves Creation dialog, select the Pick Curve Pieces

L’ button.
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¢ In the graphics window, click locations 4 and 5 (you select the
same line twice).

..................... =]

z

d In the Feature/Geometry Edit bar, name the curve bore, and
press Enter.

Creating the features

This shows you how to create the turning features.

1 Select the 2D Turned Profiles button, on the Display Mode
toolbar, to switch to a simplified 2D representation of the part.

MEE O® & =
“& To open the Display Mode toolbar, select the View > Toolbars

menu option, select the Display Mode option, then click OK.
2 Create a Turn feature.

a Click the Features ﬁ step in the Steps panel.
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b If you have the Turn/Mill module, the New Feature wizard asks
you which type of feature you want to create. Select the
Turning option, and click Next.

MNew Feature - Type

What kind of feature would you like to make?

) Tum/Mill
@ Tuming

< Back [ Mead = ”,ﬁu ,] [Cancel] [ Help ]

¢ Select Turn in the From Curve section, and click Next.
d In the Curve field select turn from the list.

Click the Pick Curve E button to select the curve graphically.
The dialog minimizes to reveal the graphics window beneath.
Click the curve you named turn earlier.

In this particular case, two objects are available for selection:
a line and a curve. Whenever your selection needs to be
clarified, FeatureCAM opens the Select dialog.

In the Select dialog, select turn, and click OK.
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e From the Finish menu button, select the Finish and Create
More option to continue creating features.

r© N

Mew Feature - Location

The top of the feature will be aligned to the £ location of the curve.
Do you want to offset the top of the feature from the curve?

Offset from curve £ location:

E 00 & ]

N\

A

- ¥ Finich =
[#1 Finish and Edit Properties
|ﬂ Finish and Create Mu:urel

3 Create a Face feature.

a In the New Feature wizard, select the Turning option, and click
Next.

b In the From Dimensions frame, select Face, and click Next.
¢ On the Dimensions page:
Enter a Thickness of 0.0625 (1.5 mm).
Enter an Outer Diameter of 4 (100 mm).
Enter an Inner Diameter of 0.
Click Next.
d Click Finish and Create More.
4 Create a Hole feature.
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a In the New Feature wizard, select the Turning option, and click
Next.

b In the From Dimensions frame, select Hole, and click Next.
¢ On the Dimensions page:
Enter a Depth of 3.75 (94 mm).
Enter a Diameter of 1.0 (24 mm).
Click Next.
d On the Location page enter a Z of 0.
e Click Finish and Create More.

5 Create a Bore feature by using the same process you used to
create the Turn feature. Use the curve named Bore.

6 Create a Groove feature.

a In the New Feature wizard, select the Turning option, and click
Next.

b In the From Dimensions frame select Groove, and click Next.
¢ On the Dimensions page:

Select a Location of ID.

Select an Orientation of X axis.

Enter a Diameter of 1.25 (31 mm).
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Enter a Depth of 0.125 (3 mm).
Enter a Width of 0.25 (6 mm).
Leave the other settings at 0.
Click Next.
d On the Location page enter a Z of -3 (-75 mm).

e Click Finish and Create More.

7 Create a Thread feature.

a In the New Feature wizard, select the Turning option, and click
Next.

b In the From Dimensions frame, select Thread, and click Next.
¢ On the Dimension page:
Select Get the thread dimensions from a standard thread.
Select OD.

In the Designation field select the 2.0000- 4.5 UNC (M50-15 for
metric).

Click Next.
d On the Dimensions page:
Select a Thread of Right hand.
Enter a Thread Length of 1.0 (24 mm).
Click Next.
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e Click Finish and Create More.

8 Create a Cutoff feature.

a In the New Feature wizard, select the Turning option, and click
Next.

b In the From Dimensions frame select Cutoff, and click Next.
¢ On the Dimensions page:

Enter a Diameter of 4 (100 mm).

Enter an Inner Diameter of 0.

Enter a Width of 0.122 (3 mm).

Click Next.
d On the Location page enter a Z of 4.5 (-112 mm).
e Click Finish.
VY
bo |
| ]

Viewing the part
You have been working in a 2D view.

To look at the part in a different orientation you can select one of
the standard predefined views. These options are available from the
Standard toolbar:

nE s o]y @0 N8 Bwe
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1 To return to a 3D view of the model, click the 2D Turned Profiles
button, on the Display Mode toolbar.

2 Click the Isometric View button on the Standard toolbar.

3 Shade the part.

a Open the Part View panel, and select bore1 under the Setup1
node.

b Click the Shade Selected button on the Display Mode
toolbar.

c Select thread1 in the Part View panel.
d Click the Shade Selected button again.

4 Click the Unshade All 28] button on the Display Mode toolbar to
return to the wireframe view.
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Simulating the toolpaths

Now you have created the features, FeatureCAM automatically:
= Selects the most appropriate tools and operations;

= Recommends machining strategies;

= Calculates speeds and feeds;

= Generates toolpaths and creates the NC code.

To view the simulated toolpath:

1 Click the Toolpaths ﬂ step in the Steps panel. This displays the
Simulation toolbar.

EMLILY N LN

2 Select the 3D Simulation option, and then click Play E to
start the simulation. If the Automatic Ordering Options dialog
appears, click OK to close it. This accepts the default ordering
options.

This displays a solid 3D rendering of the cutting process. By
default, the 3/4 view is shown when cutting or drilling the ID of
the part.

~& If the 3/4 view is not displayed, select Options > Simulation
> Round Stock from the menu, select the 3/4 view with lathe
ID work option, then click OK to close the dialog. Click the

Play E button on the Simulation toolbar to see the
changes.

3 Click the Play to Next Operation button. This displays the face
operation.
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4 Repeat step 3 to view each operation until the whole part is cut.

5 Click Eject EI This removes the simulation.

Order of manufacturing operations

The Op List tab in the Results window shows all of the operations
needed to machine the features. A yellow warning & sign next to an
operation indicates a potential problem with that operation. In this
case, if you see any warnings ignore them.

1] Operation List
5 @ Automatic Ordering —
E @ Manual Ordering ?H:’u 3“ Lin @ ﬂl @ 0
; R Operation Feature Tool
» (o finish face1 SW_Tum_80_...
o rough pass 1 turm 1 SW_Tum_80_...
finigh turm 1 SW_Tum_80_...
drill hole1 TD_10000_1.T
rough pass 1 bore1 WH_B_Small_...
finigh bore1 WH_B_Small_...
rough pass 1 groove 1 WHN_B_Grv_6...
finigh groove 1 WHN_B_Grv_6...
relief groove thread1 SW_Grv_250_...
thread thread 1 OD_UN_SW
cutoff cutoff1 SW_Cut_122_...

Results

You can control the automatic ordering of operations by using either
rules or operation templates. The 2.5D Milling tutorial looks at using
rules (see page 16).

This section changes the automatic ordering by modifying the Turn
Operation template.
To modify the template

1 Select the Automatic Ordering option on the Op List tab. This
ensures the automatic ordering rules are applied to the
operations.

2 Change the automatic ordering to group together the operations
which use the same tool.

a Click the Ordering Options button.
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b In the Automatic Ordering Options dialog, select Use template.

-

Automatic Ordering Options

Automatic operation ordering is contralled with
thesze optionz:

) Use rules
tinirize tool changes
Do fimizh cuts last
Cut higher operations first [milling anly)
tinirnize rapid distance [miling only]

@ Use template

Edit template...

iy

L

¢ Click Edit template.
3 In the Feature Order dialog:

Feature Order

Rough Facing K.
Finizh Facing
Holes

Fiatary Z milln Cancel
Firish 0D Tum Resel
Ratary 0D milling
Fough ID Tun

Finish 1D Tumn

Fough OD Groowes
Finish O0 Groowves
Fough ID Groowes
Finish 1D Grooves

0D Threads

1D Threads

Sub spindle
Uzer-defined Operations
Cutoffs

Bar Feed

Help

" Pl
:

L 4

a Select Rough OD Turn.

b Click iluntil Rough OD Turn is below Finish ID Turn.

¢ Click OK to close the Feature Order dialog.

4 Click OK to close the Automatic Ordering Options dialog.

5 Simulate the part.

a Select the Toolpaths ﬂ step from the Steps panel. This

displays the Simulation toolbar.

b Click the 3D Simulation button, and then click the Play E

button to start the simulation.

Notice that the OD roughing and finishing now happen after

the hole is drilled.

¢ Click the Stop E button when simulation is complete to exit

simulation mode.
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Part documentation (Turning)

As well as simulating the manufacturing of the part, the simulation
also generates complete tool and operations lists. The tools selected

are based on your tool database. You can print all of this
information for use as an operator's checklist.

1 Click the Details tab in the Results window to display the

Manufacturing Operations sheet.

Manufacturing Details

® Operation List
. Toal List

FMANUFACTURING OPERATION SHEET -

Part:
Setup:
Date:
Time:
Stock:
kat:

Op:1
Fis:
Toal:
Time:

Op: 2

FhA1

Setup? (1 of 1)

Tuesday, Juky 26, 2011 16:14:07

4396

Z(0.0000in., -5.0000 in) x OD 4.0000 in.
ALUMIMNUR, 111.00 Brinell,0.30 HP minfin’

m

facel (finish)

1600 SFM CWY, 0.0080 IPR
#1 (SW_Turn_80_RH)
0:18.9

halel (drill

You can review this sheet using the scroll bars.

2 Select the Tool List option at the top of the Details tab to show
the Manufacturing Tool Detail sheet. It contains all of the tools
used to create the part based on the tool crib you selected.

) You can print this documentation from the File > Print menu
option.
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Generating NC code (Turning)

FeatureCAM generates the NC code to manufacture parts on a CNC
machine. You can generate NC code after you have simulated the
part, and therefore calculated the toolpaths.

-
1 Select the NC Code J step from the Steps panel. This displays
the NC Code dialog.

2 Click the Display the NC Code ’E:"‘ button to generate the NC
code.

NC Code

® Upper tumret

M10T1/01/ ME ' CHAMGE TO TOOL #1
1551000 M4 ' SET RPM TO 1000
M20 GO =4.2 Z0.

25 il

M30 G1 »-0.0625 Z0. FO.006

M35 G1 x0.1231 20,0928 FO.006

M40 GOX10.0 250 T2z CHANGE TOTOOL # 2
45 5954 4" SET RPM TO 954

MB0 GO X0, Z0.1625

MB5 GO X0, 201

MEO GT %0, Z-1.0F0.015

MBS GO =0, 201

W70 GOX0. Z-049

Changing the post processor

To change the post processor:

1 Select Manufacturing > Post Process from the menu. This displays
the Post Options dialog.

2 Click Browse to view available post processors.

The default folder for posts is C:\Program
Files\Delcam\Examples\Posts.

3 Select your post processor and click Open.
The new post processor is displayed in the CNC File field.

4 Click OK to exit the Post Options dialog and use the new post
processor; click Cancel to exit the dialog and keep the original
post processor.

Select the Toolpaths ﬂ step from the Steps panel.
Run a simulation of the part to regenerate the NC code.
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Saving the NC code

To save an NC program:

-
1 Select the NC Code J step from the Steps panel. This displays
the NC Code dialog.

o
Click the Save NC button in the NC Code dialog.

In the Save NC dialog, accept the default filename and folder,
and click OK.

-

Save NC @1

MEC Output Directory

@ Save to cument directary:
E:\FeatureCAkd\Getting Started

() Save to other directony:

Browse...

MC Pragram Mame

@) Use the base file name for all NC programs. S etups vil
be named -2, -3, etc.

File Name:  miling2. TET
[ Save MC Program Using Short File Mame

(7 Use the zetup Part Mame for each MC program file

Selection
@ &l Setups () Current Setup
Operations List Tool Data
Tools Ligt of Al Setups F/S Data
Toals List of Each Setup M achining Configuration
HC Program
[7] Create Subfolder [] Owenvarite Existing Files
[ QK ] [ Cancel ] l Help
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Introduction to turn/mill

This tutorial introduces you to:
= Creating parts for lathes with milling capabilities.
= Mixing turning and milling features.

= Creating milling features on the outside diameter and face of the
part.

=  Simulating a turn/mill part.

&  You must have licensed the Turn/Mill option to run this
tutorial.

Start FeatureCAM (see page 2).

Create a new file (see page 4), but select a Type of Turn/Mill
Setup.

N

Preparatory steps (see page 44).

Defining the geometry (see page 44).

Creating the features (see page 47).

Viewing the part (see page 48).

Creating three radial holes on the face (see page 49).
Engraving the face (see page 50).

Creating three slots (see page 53).

= © 00 N O O »~» W

0 Simulating the toolpaths (see page 54).
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Preparatory steps

The preparatory steps define the stock and determine the
coordinate system and view.

1

oo a0 A WODN

N

On the Dimensions page of the Stock wizard:

-

Dimensions

~

What shape is the stock: () Block
@ Round
) N-Sided
Enter the dimensions of the stock:

oD

length  fe———= DD

5 0

<Back || Nex> || Finish|,| | Cancel | [ Hep |

o O T o

Select a shape of Round.

Enter an OD (outside diameter) of 3.

Enter a Length of 2.
Enter an ID (inside diameter) of 0.

Click Next until you reach the Part Program Zero page.

Select Align to stock face.
Click Next.

Click ﬂ' to position the datum of the part.
From the Finish menu, select the Finish button.

From the View menu select Center All |:

Select Options > Turning Input Modes > Diameter (DZ) from the
menu to enter coordinates as Diameter and Z values.

Defining the geometry

This shows you how to design your part.

. .'h+
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1 Draw three lines:

a Select the Geometry izt step from the Steps panel. This
displays the Geometry Constructors dialog.

Geamnetry Constructars @I

Wwhat geometny constructon do pou want to uze?

Paint L

Line S -t AN
Circle CIOJZRCACR®!
Fillet e L‘_ E: ﬁ

A CCoe =

Dimenzioh HI@@C(AAm@
E dit/Clip S

[7] Create mare than 1

b Select the Create more than 1 option, and click the Connected
Lines # button. This displays the Feature/Geometry Edit bar.

c To create two lines that define the outer profile, in the
Feature/Geometry Edit bar:

For point 1 entera D/Z1 of D 2.5, Z 0.
For point 2 entera D/Z2 of D 2.5, Z -1.5.
Press Enter to create a line.

d Create a second line with the values:
For point 2 enter a D/Z2 of D 2.75, Z -1.5.
Press Enter to create a second line.

e Create a third line with the values:

For point 2 enter a D/Z2 of D 2.75, Z -2.

FeatureCAM 2015 R3 Getting Started Introduction to turn/mill « 45



Press Enter to create a third line.

2 Create a Fillet to trim your lines.

Select the Geometry

TTLT

(i

step from the Steps panel.

In the Geometry Constructors dialog, in the list of Fillet options
click the Corner Fillet *- button.

In the Feature/Geometry Edit bar, enter a radius (R) of 0.125.

Position your mouse pointer in the corner between the first
and second lines, and click to create the fillet. The fillet
automatically trims your lines.

—;

3 To turn the part you need to chain the curves.

Q

Select the Curves BEE| step from the Steps panel.

In the Curves Creation dialog, select the Pick Curve Pieces

L’ button.

¢ In the graphics window, click the first line and then the third

line.

d In the Feature/Geometry Edit bar, name the curve Turn, and

press Enter.

B._k+
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Creating the features

This example shows you how to create the turning features.

+

1 Click the 2D Turned Profiles button, on the Display Mode
toolbar, to switch to a 3D representation of the part.

2 Create a Turn feature.

a Click the Features ﬂ step in the Steps panel.

In the New Feature wizard, select the Turning option, and click
Next.

¢ Select Turn in the From Curve section, and click Next.
In the Curve field select turn from the list.

Click the Pick Curve ﬂ button to select the curve graphically.
The dialog minimizes to reveal the graphics window beneath.
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Click the curve you named Turn earlier.
In the Select dialog, select turn, and click OK.
e Click Finish.

Viewing the part

1 On the Standard toolbar select the Isometric View button.

_—(}\ If this displays a 2D representation of the part, click the 2D
Turned Profiles button, on the Display Mode toolbar.
2 Shade the part:
a Open the Part View panel, and select turn1 under the Setup1
node.

b Click the Shade Selected button on the Display Mode
toolbar.

button on the Display Mode toolbar to
return to the wireframe view.

3 To change the view to a top view; from the Principal View !
menu button, click the Top Iil button.
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Creating three radial holes on the face

This shows you how to add three Holes to the part.

1 To return to a 2D view of the model, click the 2D Turned Profiles
button, on the Display Mode toolbar.

_—|‘\-+

4L 7

2 Create a Hole.

a Click the Features

: step in the Steps panel.

In the New Feature wizard, select the Turn/Mill option, and click
Next.

¢ In the From Dimensions field, select Hole and click Next.
In the Dimensions dialog:
Enter a Chamfer of 0.0.
Enter a Depth of 1.0.
Enter a Diameter of (.25.
e Click Finish and Create More.
3 Create a Pattern from feature:
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a In the New Feature wizard, select the Turn/Mill option, and click
Next.

In the From Feature field, select Pattern, and click Next.
Select the hole you just created and click Next.
Select Radial in the setup XY plane, and click Next.

O o 60 T

On the Pattern - Dimensions page:
Enter a Number of 3.0.
Enter a Diameter of 2.0.
Enter a Spacing Angle of 120.
Enter an Angle of 60.
f Click Finish.
g Click Cancel.
4 View the 3D wireframe representation of the part:

a Click the 2D Turned Profiles button, on the Display Mode
toolbar, to switch to a 3D representation of the part.

b Click the Isometric View button on the Standard toolbar.

Engraving the face

This shows you how to engrave the part by:
= Creating the engraving text.

= Creating a Groove feature.

1 Create a curve.

a Select the Curves B step from the Steps panel.
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b In the Curves Creation dialog, select the Curve Wizard -"(

button.
In the Curve wizard:

Curve Wizard

=)

What method of construction do you want?
() Curve from curve (@) Cther methods

() Curve from surface

What specific constructor do you want?
() Function
(") Cams
() Splines
@ Text
() Bliipse
() Rectangle
() Gears

Aa

< Back

[ MNet> | | Cancel

J |

Help

)

L8

A

Select Other methods as the construction method.

Select Text as the constructor.

Click Next.

On the Engraving Text page, configure the text properties.

-

Engraving Text

==

Text: TURMNMILL Curve name:

Path type: @) Linear () Curve

Location: M 00000 00450 D0.0000

() Circular

Angle: 50 [T Vertical text

Justification: Certer

-

Mignmert: X 0 Y 0O

Scaling: X 04 04

curvel|

[] Reverse

Spacing: [i] [

| <Back | Fnsh | | Cancel

J |

L8

Enter a Text of TURNMILL.
Select a Path type of Linear.

Enter a location of X 0.0, Y -0.045, Z 0.0.

Enter an Angle of -90.

From the Justification list, select Center.

Enter a Scaling of X 0.4,Y 0.4.
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e

Click the Font button to display the Font dialog.
From the Font list, select Machine Tool Gothic.
Enter a Size of 72.

Click OK to close the dialog.

Click Finish to close the wizard.

2 Create a Groove feature.

a

Select the TURNMILL text (curve1) in the graphics window.

Click the Features ﬁ step in the Steps panel.

In the New Feature wizard, select the Turn/Mill option, and click
Next.

In the From Curve field, select Groove, and click Next.

On the Curve page, click Next (as you have selected the text
in step 2a).

On the Location page, click Next.
On the Dimensions page:

Enter a Width of 0.0625.

Enter a Depth of 0.02.

Select Face.

Select Simple (Engrave).
Click Finish.
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Creating three slots

This shows you how to add three milled slots to the part.

1

a Click the Features step in the Steps panel.

In the New Feature wizard, select the Turn/Mill option, and click
Next.

¢ In the From Dimensions section, select Slot.

Select Make a pattern from this feature, and click Next.
d On the Dimensions page:

Enter a Length of 1.0.

Enter a Width of 0.5.

Enter a Depth of 0.25.

Click Next.

e On the Patterns page select Radial around index axis, and click
Next.

f On the Location page:
Enter a B Angle of 90.
Enter a Radius of 1.25.
Enter a Z to 0.25.
Click Next.
g On the Dimension page:
Enter a Number of 3.
Enter a Spacing Angle of 120.
h Click Finish.
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Simulating the toolpaths

To view the simulated toolpath:

1 Click the Toolpaths ﬂ step in the Steps panel. This displays the
Simulation toolbar.

2 Select a CNC file for a machine that supports live tooling. For
example:

..\Examples\Posts\TurnMill\Skeleton\skeleton-1-turret.cnc

3 Click the 3D Simulation button, and then click the Play E
button to start the simulation. If the Automatic Ordering Options
dialog appears, click OK to close it. This accepts the default
ordering options.

The toolpaths are accurately simulated including the part
rotations.

4 Click Eject EI This removes the Simulation toolbar.

54 « Introduction to turn/mill FeatureCAM 2015 R3 Getting Started



Introduction to 3D milling

This tutorial introduces you to:

= Modeling 3D surfaces.

= Manufacturing surfaces using surface milling features.
= Manufacturing operations.

= Tool selection.

= 3D manufacturing attributes.

& You must have 3D milling to perform the examples in this
chapter. These examples are only specified in inch units. You
must have the basic tool crib installed.

This tutorial shows you how to create a simple part, generate
toolpaths and output the toolpaths used to machine the part.

1 Start FeatureCAM (see page 2).

Create a new file (see page 4).

Defining the Stock (see page 56).

Defining the geometry (see page 56).

Creating the bottle surface (see page 60).
Viewing the part (see page 61).

Creating a surface milling feature (see page 63).

0 N OO g A~ OB

Simulating the toolpaths (see page 66).
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Defining the Stock

The stock is the initial material from which you cut your part.
1 On the Dimensions page of the Stock wizard:

i '
Dimensions

What shape is the stock: @) Block
) Round
() N-Sided

Enter the dimensions of the stock:

Thickness
1.0000

Width
4.0000

Length
5.0000

<Back | Ned> ||V Enish|.| | Cancel | | Help |

Enter a Thickness of 2.
Enter a Width of 3.
Enter a Length of 6.25.
d Click Finish.

2 Click OK to accept the default values of the Stock Properties
dialog.

O T 9o

Defining the geometry

This shows you how to design your part.

1 Select View > Toolbars from the menu, in the Toolbars frame:
a Select Advanced.
b Select Geometry.
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¢ Click OK.
2 Create three vertical lines:

a On the Geometry toolbar, select Vertical III from the Line
menu.

TN W O ST

b In the Feature/Geometry Edit bar, enter an XYZ of X 1, Z 0, and
press Enter.

c Create a second line by entering an XYZ of X 5.25, Z 0, and
press Enter.

d Create a third line by entering an XYZ of X 6, Z 0, and press
Enter.

o

3 Create three horizontal lines:

a On the Geometry toolbar, select Horizontal EI from the Line
menu.
b Enter an XYZ of Y 0.5, Z 0, and press Enter.

¢ Create a second line by entering an XYZ of Y 1.125, Z 0, and
press Enter.

d Create a third line by entering an XYZ of Y 1.5, Z 0, and press
Enter.

r\
[N

4 Create a through line:

a On the Geometry toolbar, select Point, Angle from the Line

menu.
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b In the Feature/Geometry Edit bar, enter an angle A of 30.

¢ In the graphics window, click at the intersection between the

second horizontal and second vertical lines, at point@, to
create a through line.

0)

\
| ¥
[

5 Create arcs.

a On the Geometry toolbar, select 2 Pts, Radius from the Arc

menu.

b In the Feature/Geometry Edit bar, enter a radius R of 0.5, and
click the vertical line around point (2 and the horizontal line

around point@.

@ O
a4

A
I
[

¢ Create the second arc:

In the Feature/Geometry Edit bar, enter a radius R of 1.0, and
click the horizontal line around point @ and the through line

around point ®.

©0JO),
N\

ey
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d Create the third arc by clicking the through line around point
(® and the horizontal line around point @.

®Q0
\

NN

L—/ -
4

6 To mill the part you need to chain the curves.

o
JEAR

a Select the Curves B step from the Steps panel.

b In the Curves Creation dialog, select the Pick Curve Pieces

L’ button.

¢ Click at the intersection of the vertical and horizontal line at
point and at the intersection of the vertical and horizontal
line at point @,

N\

a
= :
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Creating the bottle surface

1 Select the Surfaces d step from the Steps panel.
2 In the Surface wizard, select Surface of Revolution, and click Next.

i B
Surface Wizard ﬁ

What method of construction do you want?
(@ From curves () From one surface

() Primitive surface () From muttiple sufaces

What specific constructor do you want?
(7) Extrude
(@ Surface of Revolution
() Swept Surface
() Ruled Surface
() Coons
(7) Curve Mesh
() Lofted Surfface
(") Cap Surface

<Bsck | Net> | | cancel | | Hep |

L

3 On the Surface of Revolution page:

( Surface of Revolution ﬂw
Surface name:  sif1 Construction method
Curve: (@ Custom line
- () Kefodis
hffomet -] S
(D) Z-fodis
Start angle:
1]
End angle: e
L B h—
| <Back |[ Fnsh | | Cancel | | Hep |
L

a Enter a Start Angle of 0.
b Enter an End Angle of 180.
c

FeatureCAM automatically selects your chained curve in the
Curve field.
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d In the Axis field, click the Pick line ﬂ button, and select the
horizontal line around point @,

{
roo -
(=l :

Ty
A1 l

Viewing the part

1 To change the view to an isometric view, click the Isometric
button on the Standard toolbar.

2 Control how the part is displayed using the Viewing Options.
a Select Options > Viewing from the menu. This displays the
Viewing Options dialog.
b Select the Show surface boundaries only option, and click
Apply.
This displays the surfaces as only their outer boundaries and
trimmed loops. No additional lines are drawn in the interior of

the surface. This makes the display of larger models much
faster.
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c Deselect the Show surface boundaries only option, and click
Apply.

This displays the surfaces with lines in the interior of the
surface. This aids visualization, but for large models, it makes
the display of the part slower.

d Enter a Surface fineness Wireframe of 20, and click Apply.

This displays the surfaces with more lines. Decreasing the
value of Surface Fineness improves the display quality but
slows down the graphics.

e Click OK to close the dialog.

3 From the Hide menu on the Advanced toolbar, click the Hide
All Geometry button.

4 From the Show menu on the Advanced toolbar, click the
Show all surfaces button.

5 Click the Shade button, on the Standard toolbar, to shade the
part.
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Creating a surface milling feature

This shows you how to create the surface features and select the
toolpath strategies.

1 On the Standard toolbar, click the Select button, and select
the surface (srf1). On selection it turns red.

2 Select the Features = step from the Steps panel.

3 In the New Feature wizard, in the From Surface frame, select the
Surface Milling option, and click next.

' ™
MNew Feature m
What kind of feature would you like to make?
From Dimensions From Curve
) Hole () Boss ) Round
() Rectangular Pocket ) Chamfer  (7) Side
() Slot () Groove
() Step Bore () Pocket
IE:EI Thread Milling Erom Feahre
© Face () Group () Pattem
() User
() Toolpath
From Surface

@ Surface Miling

Exract with
FeatureRECOGNITION
< Back [ MNead > ”ﬂ“i-‘lvl ’ Cancel l ’ Help l

A

L

4 On the Part Surface page click Next.
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5 On the New Strategy page, select the Choose Rough, Semi Finish,
and Finish... option, and click Next.

~

-
New Strategy

What do you want to do?

(@) Choose rough, semifinish, and finish
operations to completely machine this @

=
3

| <Back | Nedt> |[[* Enish|.| | Cancel | [ Hep |

L 4

6 On the Rough page:

-

(7) Choose a single operation

New Strategy - Rough

What roughing strateqies do you want to use?

Tool Diameter: 0.5
Finish Allowance: 0.05
Tolerance: 0.005
@ Z Level Rough
Classify slices as: @) 30 Pocket
(") 3D Boss
Flat suface support
() Plunge
Honeycomb
) None
| <Back || Ned> |[[#1 Finish|,| | Cancel | | Help |

L

a Select the Z Level Rough option.
b Select Classify slices as 3D Pocket.
¢ Click Next.
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7 On the Semi-Finish page, select None, and click Next.

~

-
New Strategy - Semi-Finish

What semifinishing strategies do you want to use?
Tool Diameter: 0.5

@ Finish Allowance: 0.05
0.001

Tolerance:

() Parallel
Direction (@) X parallel Y parallel
Farallel angle; |0

() Z Semi

() Z Finiish

@ None

| <Back || Ned> |[[#1 Finish|.| | Cancel | | Help |

L A

8 On the Finish page, select Isoline.

-
New Strategy - Finish

What finishing strategies do you want to use?

Tool Diameter: @) Automatic (surface curvatune)

a (") Settool diameter 0.5
0.001

Tolerance:

() Horizontal + Vertical
Slope boundary &0
Slope overlap 0

@ lsoline

() Parallel

) Z Level

) None

| <Back | Ned> |[[*f Erish|.| | Cancel | [ Hep |

L 4

9 Click the Finish button.
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Simulating the toolpaths

To view the simulated toolpath:

1 Click the Toolpaths “ step in the Steps panel. This displays the
Simulation toolbar.

2 Click the 3D Simulation button, and then click the Play E
button to start the simulation. If the Automatic Ordering Options
dialog appears, click OK to close it. This accepts the default
ordering options.

& Note how the toolpaths are accurately simulated including
the part rotations.

3 Click Eject EI This removes the Simulation toolbar.
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Introduction to wire EDM

This tutorial introduces you to the basics of creating wire EDM
toolpaths. It looks at:

= Setting up your material and wire thickness.
= Creating wire EDM features.

= Specifying a wire EDM cutting strategy.

= Simulating wire EDM toolpaths.

&  You must have licensed the Wire EDM option to run this
tutorial.

Start FeatureCAM (see page 2).

Create a new file (see page 4), but select a Type of Wire EDM
Setup.

N

Defining the stock (see page 67).

Creating the profile (see page 68).

Creating a wire EDM feature (see page 70).
Simulating the wire EDM toolpath (see page 71).
Generating NC code (Wire EDM) (see page 73).
Adding a taper angle (see page 74).

0o N OO a b~ W

Defining the stock

The preparatory steps define the stock and determine the
coordinate system and view.
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1 On the Dimensions page of the Stock wizard:

' N
Dimensions

What shape is the stock: () Block
@ Round
() N-Sided

Enter the dimensions of the stock:

- oD
4
length  fe———= \pp
5 0
<Back [ Ned > | [ Enish|.| | Cancel | | Help |

Enter a Thickness of 0.5.
Enter a Width of 4.
Enter a Length of 4.

o 0 T 9

From the Finish menu button select the Finish button.

Creating the profile

This step defines the profile.

A

[‘\,‘_
1= X

MNB

1 Select the Curves _ step from the Steps panel.

2 In the Curves Creation dialog, select the Curve Wizard K button.
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3 In the Curve Wizard:

-

Curve Wizard

What method of construction do you want?
() Curve from curve @ Other methods

() Curve from surface

What specific constructor do you want ?
() Function
~) Cams
() Splines

() Text
() Hlipse
@ Rectangle

) Gears

<Bsck [ Net> | [ Cancel | [ Hebp

)

J

a
b

(9

Select a construction method of Other methods.

Select a constructor of Rectangle.

Click Next.

4 On the Rectangle page:

o B
Rectangle @
Curve name;  curvel @ Use comer, width, and height
() Use center, width, and height
Comer point: M 1 1 0.0000
Comer Radius:
0.5]
Angle: Blewation:
0 +"T'_'_'_'_—"1 0.0000
Width: Height
Az 2

|| Create as arcs and lines

| <Back || Fnsh | | Cancel | | Hep |

4

= 0o o O T 9

Select Use corner, width, and height.

Enter corner point of 1, 1, 0.
Enter a corner radius of 0.5.
Enter a Width of 2.0.

Enter a Height of 2.0.

Click Finish.
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Creating a wire EDM feature

This shows you how to create a wire EDM feature.

1 Click the Features ; step in the Steps panel.

2 In the New Feature wizard, select the Die option in the 2 Axis
frame, and click Next.

MNew Feature Mw
What kind of feature would you like to make?
2 fods 4 fods
@ Die () Die
) Punch ) Punch
() Side () Side
) Rapid ) Rapid
From Feature
() Group () Pattem
@) User

[] Make a pattem from this
feature

[7] Bdract with
FeatureRECOGNITION

<Back || Ned> || Ersh .| | Cancel | | Help |

L A

3 On the Curves page, click the Pick curve or geometry ﬂ button,
select the curve you created, and click Next.

A

r\\‘u_
1 x

M&

4 On the Location page, click Next.
5 On the Dimensions page, enter a Thickness of 0.5 and click Next.
6 On the Start page, click Next.
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7 On the Strategies page:

Mewr Feature - Strategies

What strategies would vou like to uze to cut thiz Die feature?

Operations: [ Retract - ]

Cutaff [] Contaur
Frirnary Cut Dir: @ oW ) COw

[ Reverse Cutaff
Retract Length: 0.0200 in. O Us:e on both ends of

zhim pazzes
Stop Length: 0.5000 in.
Owerlap: 0.0000 in. }i Sligg Locl
w01 -

0.0000

[ Skim Pasz Optionz.... ]

[<Back ][ MHedt ”,ﬁ“finish ,] [ Cancel] [ Help ]

In the Operations field select Retract.
Select the Cutoff option.

Select the Contour option.

Click Finish.

O T 9

Simulating the wire EDM toolpath

Now you have created the features, FeatureCAM automatically:
= Selects the most appropriate tools and operations;

= Recommends machining strategies;

= Calculates speeds and feeds;

= Generates toolpaths and creates the NC code.

To view the simulated toolpath:

1 Click the Toolpaths ﬂ step in the Steps panel. This displays the
Simulation toolbar.

P e I-@sﬁ[ll LT R o e

2 Click the 2D Simulation E button on the Simulation toolbar.

Center the Simulation Speed ~ ' slider to specify the simulation
rate.

4 From the Simulation Next menu button, select the Play to

Next Operation button to see the retract operation. If the
Automatic Ordering Options dialog appears, click OK to close it.
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& To slow down the simulation, drag the Simulation Speed
~ slider to the left.

L

5 Click the Play to Next Operation button again to see the cutoff
operation.

¥
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6 Click the Play to Next Operation button again to see the final
contour operation.

7 Click Eject EI

Generating NC code

FeatureCAM generates the NC code to manufacture parts on a CNC
machine. You can generate NC code after you have simulated the
part, and therefore calculated the toolpaths.

-
1 Select the NC Code '\}\1 step from the Steps panel. This displays
the NC Code dialog.

2 Click the Display the NC Code ’EZH‘ button to generate the NC
code.
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Open the Part View panel, selec

Adding a taper angle

This example shows you how to add a draft angle to a wire EDM
part.

node, and click the Properties @m button on the
Feature/Geometry Edit toolbar.

In the Properties dialog for die1:

t the die1 feature from the Setup1

P
Die Properties - diel

M diel

[ Dimensions | I& Location | X, Strategy | € Start | ®5 Misc|

Curve... [T Curve at bottom

Thickness

ﬁ 0.5000

Taper (Mot Used For Pocketing/Zigzagaing)

@ MNone
() Constant Left
10 deqg. 0 taper req.
(7) Variable Variable Taper...
Spline tolerance
0.0010 [ Reduce curve A 0.0000

Cancel Apply Preview ] [ Help

L

a Select Constant.

b Select a taper type of Left.
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c Enter a deg. of 10 as the taper angle.
d Click Apply.

3 Click the Hide Stock button from the Hide menu on the
Advanced toolbar.

%k A Ry GO@BE

4 Click the Isometric View button on the Standard toolbar.

6 Change the taper type back to Left, and click OK to close the
Properties dialog.

7 Select the Toolpaths ﬂ step from the Steps panel.
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8 Click the 3D Simulation button, and then click the Play E
button.

9 Click the Select button on the Standard toolbar.
10 Click inside the curve. FeatureCAM deletes that part of the stock.

11 Click Eject IEI

12 From the Show menu on the Advanced toolbar, click the
Show Stock button.
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